Ticket #2916 Debian packages
[freeside.git] / debian / rules
index c658278..be2a5a2 100755 (executable)
@@ -93,7 +93,7 @@ build-stamp:
        dh_testdir
        # Add commands to compile the package here
        
-       ( cd FS/ && $(PERL) Makefile.PL PREFIX=$(TMP)-lib/usr INSTALLDIRS=vendor && [ -e Makefile ] || perl Makefile.PL && make )
+       ( cd FS/ && $(PERL) Makefile.PL INSTALLDIRS=vendor && [ -e Makefile ] || perl Makefile.PL && make )
        
        #install this for freeside-setup
        install -d $(DIST_CONF)
@@ -125,12 +125,11 @@ install-stamp: build-stamp
        # debian/<package>-whatever.
 
        install -d $(FREESIDE_DOCUMENT_ROOT)
-       install -d $(TMP)-lib/usr/bin/
        install -d $(TMP)-webui/usr/local/etc/freeside/
        install -d $(TMP)/usr/local/etc/freeside/
        install -d $(FREESIDE_CACHE)/masondata #MASONDATA
 
-       ( cd FS/ && $(MAKE) -e DESTDIR=${TMP}-lib install)
+       ( cd FS/ && $(MAKE) -e DESTDIR=${TMP} install)
 
         # Install configuration files
        install -d -o freeside ${FREESIDE_CONF}